Advanced Search

Author Topic: Custom Music Not Looping  (Read 2090 times)

0 Members and 1 Guest are viewing this topic.

April 06, 2016, 02:13:46 PM
Read 2090 times

Offline BombHornet

  • Standard Member
  • Date Registered: September 25, 2013, 11:18:23 PM

    • View Profile
Custom Music Not Looping
« on: April 06, 2016, 02:13:46 PM »
I was trying to make my ogg file loop at the timeframe I wanted, but when I tested it, It only played all the way to where it fades out and then it starts from the very beginning as usual. What I did was export it in Audacity and make a LOOPSTART and LOOPEND label for the timeframe that I wanted to repeat. Does anybody have a better method of doing this?

April 06, 2016, 06:17:06 PM
Reply #1

Offline Rozark

  • MM8BDM Extender

  • Mr. Explorer
  • *********
  • Date Registered: August 28, 2011, 04:46:04 PM

    • View Profile
    • Rozark #0873
Re: Custom Music Not Looping
« Reply #1 on: April 06, 2016, 06:17:06 PM »
Manually loop it yourself.
Make sure to cut out the .5 seconds or so of blank space at the beginning of the track.
Shift click the play button to test the loop so it works flawlessly.
Unless the song has an intro that doesn't go with the main loop, there's no reason to use LOOP_START, as that's used more to make sure intros get a chance to play at least once.

April 06, 2016, 07:28:22 PM
Reply #2

Offline Russel

  • MM8BDM Extender

  • Doc Croc
  • **********
  • Date Registered: December 17, 2010, 11:11:25 PM

    • View Profile
Re: Custom Music Not Looping
« Reply #2 on: April 06, 2016, 07:28:22 PM »
the tags are LOOP_START and LOOP_END, you must include the underscores.
you need to precede times that are less than a minute into the song with a colon

For five seconds, the tag should be called LOOP_START and the value should be :5.00

April 06, 2016, 07:38:34 PM
Reply #3

Offline BombHornet

  • Standard Member
  • Date Registered: September 25, 2013, 11:18:23 PM

    • View Profile
Re: Custom Music Not Looping
« Reply #3 on: April 06, 2016, 07:38:34 PM »
The music I'm using is this one BTW:

So what I want to do is to make it loop endlessly if possible between 0:04.559 and 2:03.92 while keeping the intro at the beginning.

April 06, 2016, 08:41:02 PM
Reply #4

Offline Rozark

  • MM8BDM Extender

  • Mr. Explorer
  • *********
  • Date Registered: August 28, 2011, 04:46:04 PM

    • View Profile
    • Rozark #0873
Re: Custom Music Not Looping
« Reply #4 on: April 06, 2016, 08:41:02 PM »
The deed is done.
https://www.mediafire.com/?28032oy6981fv0m

- It's an .ogg, the normal file extension, compression reasons.
- Stereo converted to Mono, compression reasons.
- Your loop start was at around 5 seconds, not 4.
- Your overall loop was about 1 minute, not 2.

Just insert this into whatever custom music pack you plan on using and it'll play as requested (Intro plays once, with the main part being looped)

April 06, 2016, 09:17:07 PM
Reply #5

Offline BombHornet

  • Standard Member
  • Date Registered: September 25, 2013, 11:18:23 PM

    • View Profile
Re: Custom Music Not Looping
« Reply #5 on: April 06, 2016, 09:17:07 PM »
Quote from: "Rozark Kyouko"
The deed is done.
https://www.mediafire.com/?28032oy6981fv0m

- It's an .ogg, the normal file extension, compression reasons.
- Stereo converted to Mono, compression reasons.
- Your loop start was at around 5 seconds, not 4.
- Your overall loop was about 1 minute, not 2.

Just insert this into whatever custom music pack you plan on using and it'll play as requested (Intro plays once, with the main part being looped)

Oh, I was already able to loop the theme, but thanks anyway Rozark! :)