Advanced Search

Author Topic: Slade not saving offsets  (Read 511 times)

0 Members and 1 Guest are viewing this topic.

March 04, 2021, 06:42:48 PM
Read 511 times

Offline Trigonomancer

  • Standard Member

  • Always open to criticism.
  • Date Registered: September 08, 2020, 03:22:31 AM

    • View Profile
    • I make some pixel art!
Slade not saving offsets
« on: March 04, 2021, 06:42:48 PM »
[SOLVED]

Fix: If Slade refuses to save your offsets, simply delete the sprite from the pk3 and re-import it using the import button, adjust the offset manually and save the sprite by selecting another file (click another file and click yes on the save prompt) then save the pk3 with Ctrl+S, you have to do it one by one unfortunately  :| .
 Lazy Purple screaming "That's because it makes no f'ing sense


Hello, I'm finishing a skin and it has very odd variations in width so simply centering it won't suffice, the problem is Slade refuses to save any changes in my offsets! I used Trillster's skin generator for the naming and auto set their offsets to Monster (GL friendly), lowered all of their heights to 1 lower then went to adjust all of them manually. Only for me to save (the sprites) then click on the save icon at the top left just to make sure then close the pk3 and come back to all of them having my manual changes undone.

[Update]
I tried instead, saving them by selecting another sprite like someone recommended me and it worked... for one frame, and the others magically reverted their offsets to when I set them to monster (GL friendly)

[Update - 2]
Now I want to know if anyone else ever had this issue with Slade, I didn't change any settings except for the font being monospace (which it also reset for some reason lol)

Example of the issue happening:

(click to show/hide)